Obsługa nieaktualnych wersji php

Na tej stronie znajdziesz wszelkie informacje dotyczące obsługi nieaktualnych wersji php na hostingach cyber_Folks.

Najważniejsze definicje

Co to jest PHP?

Większość stron jest stworzona w języku programowania zwanym PHP (Hypertext Preprocessor). To dlatego nieodłącznym elementem każdego hostingu jest interpreter PHP, który potrafi odczytać ten język, a następnie wyświetlić stronę internetową użytkownikowi. Pierwsze wersje PHP sięgają roku 1995. Od tamtego czasu regularnie wydawane są nowsze wersje interpretera PHP. Nowe wersje zawierają ulepszenia w zakresie stabilności i bezpieczeństwa witryn internetowych. Jednocześnie wypierają one stare wersje, które przestają być oficjalnie wspierane po określonym czasie.

Co to jest płatne wsparcie starych wersji php?

W ofercie cyber_Folks znajdziesz dwie linie hostingów różniących się obsługiwanymi wersjami PHP. Pierwsza linia to hostingi LTS (Long Time Support). W jej skład wchodzą następujące hostingi: Hosting WWW, PrestaShop, WordPress, WooCommerce. Obsługują one wersje PHP od 5.2. Druga linia to hostingi z dopiskiem v2.0 czyli: Hosting WWW v2.0, Hosting WordPress v2.0. Obsługują one tylko aktualne wersje PHP zgodne z powyższym kalendarzem wsparcia. Ponadto wyróżniają się niższą ceną odnowienia niż hostingi LTS z obsługą starych wersji.

Kalendarz wsparcia

Wersja PHPObsługaOficjalne wsparcie doWsparcie cyber_Folks do
5.2płatne06.01.201106.01.2011
5.3płatne14.08.201414.08.2014
5.4płatne03.09.201503.09.2015
5.5płatne10.07.201610.07.2016
5.6płatne31.12.201831.12.2018
7.0płatne10.01.201910.01.2019
7.1płatne01.12.201901.12.2019
7.2płatne30.11.202030.11.2020
7.3płatne06.12.202106.12.2021
7.4płatne28.11.202228.11.2022
8.0w cenie pakietu26.11.202326.05.2024
8.1w cenie pakietu25.11.202425.05.2025
8.2w cenie pakietu08.12.202508.06.2026
8.3w cenie pakietu23.11.202623.05.2027
terminy wsparcia konkretnych wersji php pochodzą z oficjalnej dokumentacji twórców php dostępnej tutaj.

Jak zarządzać wersjami PHP?

Przydatne informacje

Cel? Bezpieczna infrastruktura

Zależy nam, aby jak największa część klientów hostingowych cyber_Folks, utrzymywała swoje strony internetowe na najnowszych i wspieranych wersjach PHP. W tym celu można znaleźć w naszej ofercie kategorie hostingowe wspierające tylko nowe wersje PHP. W zamian cena odnowienia tych hostingów jest tańsza od hostingów z linii Long Time Support.

Musisz korzystać ze starej wersji php?

Chcesz utrzymywać stronę na starej wersji PHP? W cyber_Folks również jest to możliwe. W tym celu możesz skorzystać z hostingów linii LTS. Wspierają one wersje PHP od wersji 5.2 do najnowszej dostępnej. Ich cena odnowienia jest wyższa niż hostingów wspierających tylko wersje aktualne.

Co to znaczy „aktualna wersja php”?

Twórcy PHP w swojej oficjalnej dokumentacji zamieszczają termin do którego konkretna wersja PHP jest wspierana. Jeżeli jakaś wersja PHP jest wspierana, to oznacza, że są do niej wypuszczane na bieżąco łatki bezpieczeństwa. Poniżej znajdziesz kalendarz, w którym wypisaliśmy poszczególne wersje PHP i daty wsparcia.